Start

To develop scripts, you must:

  • Install Visual Studio;
  • Have a botbeetle version older than 5.3;
  • Download a template project of creating scripts;
  • Have a basic knowledge of programming languages or desire to learn it;
  • Get acquainted with the functions of internal API.

Every time you create a new script, it is advisable to check for botbeetle updates. If a new version is available, you must also download a new script project template.

API functions will be changed and supplemented. If possible, newer versions will support the old, but since this is only the beginning of the automation development, incompatible changes are possible.

It is good practice to use the same versions of products for development. For example, for botbeetle.5.3 use the template version 5.3.